One or more field types are not installed properly. Go to List settings page to delete these fields. Error while viewing Manage Content and Structure Page.

Posted: January 9, 2012 in Errors, Migration, Sharepoint 2010
Tags:

In SharePoint 2010 publishing site,  when you go to Site Settings -> Manage Content and Structure menu, you will get an error message saying One or more field types are not installed properly. Go to List settings page to delete these fields with an associated correlation ID.

This seems to be an issue created when you migrate your SharePoint 2007 site to SharePoint 2010. All the sub-sites of the current site will also have the same issue.

Reasons for the Issue :

  • The publishing site uses SharePoint Server Publishing Infrastructure to support the publishing features in SharePoint.
  • This feature automatically creates an internal List “Relationships List” which is used to store the variations details.
  • This list is normally not visible in View All Site Content menu but you can browse it through the url http://site_url/Relationships%20List/allitems.aspx.
  • The actual issue is after migration of the site, the list will have a column GroupId which is of type Text. But actually it should be GroupGuid with type as GUID.
  • So we need to resolve this column name & type inconsistency.

Solution for the Issue :

  • You will not be able to delete and re-create the column since SharePoint doesn’t support creation of column of type GUID through UI.
  • So only way is to delete and re-create the list.
  • Go to Site Settings -> Modify All Site Settings -> Site Collection Features and deactivate SharePoint Server Publishing Infrastructure feature.
  • This removes the association between the feature and the Relationships list, which allows you to delete the list.
  • Navigate to the URL http://site_url/Relationships%20List/allitems.aspx and delete the list from the list settings.
  • Now go to site collection features and activate the SharePoint Server Publishing Infrastructure feature.
  • Note that Relationships list will be created automatically. You can check the same by navigating to the URL as states above.
  • You can check the list containing the column GroupGuid of type GUID.

Now check your Manage Content and Structure page which will be working fine. Hope it helps 🙂

Advertisements
Comments
  1. Marty says:

    YES! thank you!!

  2. Akisha Anthony says:

    Great blog. The only problem for me is I am experiencing this issue at the site level. It appears at the site level, the Relationships Lists does not exist. It is only at the Site Collection level. Do you have any recommendations?

  3. vikash says:

    its very good blog, it solved my problem

  4. Fabio says:

    great post!!

  5. Sticks says:

    Fantastic find and fix – thank you so much !!!

  6. Rani says:

    Hi,
    The relationships list is created with all the column names and types as mentioned above. So i don’t think that is the case with us. We are facing this issue for one of the client , when he tries to edit any item from his personal view. If he edit the item from the standard public view, then no issues. However, irrespective of the error, the data is saved to the list. I have been looking for solution in web for hours, but couldn’t get a clue other than the relationships list. Can you please help me…

    Thanks

  7. Joe says:

    I’m having aforementioned issue with a site collection and tried performing your solution, but when I attempt to executing step 6 I receive the following error: “A duplicate content type name “Resource” was found.” What should I do?

  8. Joe says:

    Deletion of the relationship list at http://site_url/Relationships%20List/allitems.aspx is step 5. Since my problem happened at step 6 then obviously I’ve already done that. What do you mean by “don’t have a GroupGuid column”? How can there be a GroupGuid column if there is no relationship list?

    I need some real help here to get this fixed because my user is having additional problems now, besides not being able to bring up the Manage Content and Structure, due to my not being able to turn the SharePoint Server Publishing Infrastructure feature back on.

  9. Joe says:

    I do know how to read, so yes, I fully understand the meaning of: “The actual issue is after migration of the site, the list will have a column GroupId which is of type Text. But actually it should be GroupGuid with type as GUID.” Naturally, that is what I saw in our site collection where Manage Content & Structure was giving the aforementioned error, hence my reason for attempting to employ the given solution. Unfortunately, the solution did not work in my case, hence the reason for my original post.

    I looked at the solution posted in the other blog. Although I am a site collection administrator for the problem site, I do not have the power to create a new site collection, nor edit configuration files for a site. If need be I will get our Sys Admin involved but first I’d like to ask a question. I noticed that we have other site collections, which underwent the same upgrade process from SP2007 to SP2010 that our problem site did, that also have the Relationship List with the incorrect “GroupId” column, yet they do not exhibit the issue with Manage Content & Structure that our problem site does. I am wondering how this could be, and if it might be possible to copy the Relationship List from one of the sites that does not have a problem with it to our problem site, and whether that is likely to fix the problem or make things worse than they already are?

  10. udaya says:

    Hi,
    I am facing this issue in share point 2010 Form library,when i am going to delete the document i am facing this.And i removed all columns and then also facing the same error.please help to me.
    Thank u…

  11. Fish Happy says:

    U r da man of many emotions and of the awesomest projection of the goodness of the well so I am happy to thank you for the balloons of help that you have given to me of excited fish boom!

  12. We are a group of volunteers and starting a new scheme in our
    community. Your website provided us with valuable info to work on.
    You’ve done an impressive job and our entire community will be thankful to you.

  13. sleep apnea says:

    At this time it appears like Movable Type is the top blogging platform available right now.
    (from what I’ve read) Is that what you’re using on your blog?

  14. celebs says:

    Right now it looks like WordPress is the top blogging platform
    available right now. (from what I’ve read) Is that what you’re using on your blog?

  15. Elance says:

    I just could not depart your site prior to suggesting that I really enjoyed the
    standard info a person provide for your guests?
    Is gonna be again continuously in order to inspect new posts

  16. […] or delete any list in the site affected. For more detail on the error, please refer to this webpage One or more field types are not installed properly. Go to List settings page to delete these fields.… After several hours of research for solution with no luck, we decided to do a visit to the low […]

  17. Manh Le says:

    Hello there,
    Thank you for the explanation. Nice work done. For anyone that can not solve the issue with this approach, please visit my website at http://lesworkspace.com/one-or-more-field-types-are-not-installed-properly-after-sharepoint-2010-upgrade/ for an alternative solution.

  18. kancharla says:

    Excellent…. This worked for me like a gem. I will post the same in my blog and refer your blog URL there.

  19. RB says:

    Thanks a lot !! you saved me a lot of time !

    you r the man !

  20. Mohamed Asik says:

    Hi All,

    I am getting same error in office 365 Site.I am copying list from SharePoint 2013 to office 365.I got the error.Please help me on this ASAP.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s